Since the 5.1 update states that it's compatible with version 5.1.1 IOS, how about making it actually compatible with it? If I had known it would be compatible with only IOS 6.0 and above I would...