PDA

View Full Version : Collection Timing Off



psxnitro
05-30-2013, 02:11 AM
Anyone else experiencing collection times increasing by about 15min increments? :confused:

I have a timer app that I use for collecting on time. But from time to time, when my timer goes off to signal that my building is ready to be picked up, the building will still have 15, 30, 45, or sometimes 1:45 left on it.

It almost seems like the server seems to register my collections late, and screwing up my timings. :mad:

TZora
05-30-2013, 02:44 AM
half of my buildings are now 2.30 hours out of sync and no matter how much i wait to put them back in sync but nothing seems to be helping. the gap keeps increasing ..

BigMoney
05-30-2013, 02:48 AM
What I don't get is how one of my two buildings (e.g. two Rock Cafes) will become out of sync, but not the other one. One is on time, and the other ends up being increasingly off.

TZora
05-30-2013, 03:30 AM
What I don't get is how one of my two buildings (e.g. two Rock Cafes) will become out of sync, but not the other one. One is on time, and the other ends up being increasingly off.
just like half of my builds r out of sync and half r still due at the old time. thought i was going crazy or i forgot to collect half of my hood. happened same with one of my 48 hour builds a few days ago. i thought i forgot to collect it but may be it was cuz of this sync problem. gree ... sigh

psxnitro
05-30-2013, 03:42 AM
Glad I'm not the only one thinking I'm going nuts, my 48hr collects are messed up right now by almost half a day... even though I collected them all at the same time.

N41LZ
05-30-2013, 05:05 AM
This has been happening for at least the past month now - before Packer Heights
Most frustrating is I used to be able to collect all 12hr buildings 1hr before bedtime now it's 3 HOURS after the time i should be asleep..... hurray
From everyone i know who raised a ticket, they've been told it's a server issue, nothing can be done and to STFU

(CCK) Cam
05-30-2013, 05:56 AM
Anyone else experiencing collection times increasing by about 15min increments? :confused:

I have a timer app that I use for collecting on time. But from time to time, when my timer goes off to signal that my building is ready to be picked up, the building will still have 15, 30, 45, or sometimes 1:45 left on it.

It almost seems like the server seems to register my collections late, and screwing up my timings. :mad:Same happens to me,it gets later and later.

mxz
05-30-2013, 08:04 AM
As has been reported in other threads - you need to do a server sync before exiting the game. Or exit and log back in right away.

RijilV
05-30-2013, 09:01 AM
refreshing your rivals list is an easy way to let your client sync back to the server, or go back to banking.

Swedevil
05-30-2013, 09:56 AM
As has been reported in other threads - you need to do a server sync before exiting the game. Or exit and log back in right away.
This does not always work. I did this last night before bed and woke up this morning to 7 out of 12 buildings that should've been collectible without a collection ready...

TZora
05-30-2013, 10:02 AM
i've tried almost everything i can to make it work but looks to me there's something wrong at the server end. and i think the only way to make it work is not to collect for 24 hours and wait for each and every building to be ready for collection.

PuckinWebGuy
05-30-2013, 10:03 AM
I don't have this with any of my big buildings, but for some reason, I see it with the laundromats. I'll collect and leave, then come back in an hour and only one laundromat will be ready. Doesn't bother me, but probably the same issue.

dudeman
05-30-2013, 10:07 AM
As has been reported in other threads - you need to do a server sync before exiting the game. Or exit and log back in right away.


refreshing your rivals list is an easy way to let your client sync back to the server, or go back to banking.

That's not what's happening here. The building timers have been, for lack of a better word, totally f*cked for some time now. Sh!t goes out of synch for no reason at all. Say you make a collection and do whatever, bank it or call the server some other way. You come back for the next collection of the same buildings and half are ready but the other buildings that were collected at the same time still have several minutes left on the timer.

Of course, this has also been mentioned in other threads but it's much easier to just assume people have no idea what they're talking about, right? :rolleyes:

murf
05-30-2013, 10:11 AM
That's not what's happening here. The building timers have been, for lack of a better word, totally f*cked for some time now. Sh!t goes out of synch for no reason at all. Say you make a collection and do whatever, bank it or call the server some other way. You come back for the next collection of the same buildings and half are ready but the other buildings that were collected at the same time still have several minutes left on the timer.

Of course, this has also been mentioned in other threads but it's much easier to just assume people have no idea what they're talking about, right? :rolleyes:

A couple minutes off is annoying...having all your 12 hrs ready to collect, but your Rock Cafes are 4hrs off, WTF?

dudeman
05-30-2013, 10:13 AM
A couple minutes off is annoying...having all your 12 hrs ready to collect, but your Rock Cafes are 4hrs off, WTF?

A few minutes off for over a month adds up to hours off at this point, so even a few minutes is more than just annoying.

mxz
05-30-2013, 02:56 PM
If you sync too quick sometimes the messages about which buildings were collected dont make it. I started doing a rivals list refresh then going to someone's hood and haven't had a problem since.

If you want to know why that is, you can probably ask Lupo.

murf
05-31-2013, 07:15 AM
This is getting out of control. So I collect my 6hr's this morning, bank (before syndicate), go do some jobs for Pay What You Owe, then log off. I come back 1.5 hrs later, all my 6's are robbed, but it looks like my money is still in the bank.

Could this be right?

murf
05-31-2013, 07:16 AM
This is getting out of control. So I collect my 6hr's this morning, bank (because war starts today), go do some jobs for Pay What You Owe, then log off. I come back 1.5 hrs later, all my 6's are robbed, but it looks like my money is still in the bank.

Could this be right?

domw001
05-31-2013, 12:50 PM
I don't have this with any of my big buildings, but for some reason, I see it with the laundromats. I'll collect and leave, then come back in an hour and only one laundromat will be ready. Doesn't bother me, but probably the same issue.

That Laundromat is the one that is annoying me at the moment. I know it's a 5 minute output building but I don't expect to return to the game after 30 minutes and see the timer counting down at 4:58. It's just symptomatic of what I can see as a frustrating bug.

I'm sure the timer skwiffed my NC payout too, I have 4 other buildings collecting at the same time but the NC wasn't ready when expected

Jerle
06-02-2013, 02:28 AM
Thanks for the reports everyone. I've seen some random comments on this in other threads, but this thread has enough detail that I actually have a theory for what might be going on - it's very likely a sync problem but it will take a little more digging to determine exactly where.

For anyone who experiences this issue regularly, here's how you can help:

Tomorrow or whenever you next start a big collect cycle, take note of exactly what time and how many/what type of buildings you collect from. Then when you come back, note the states of all of those buildings. PM that information to me along with your invite code, and I should be able to reconstruct the sequence of events the server saw from the logs to fine what I need. I only need this for one cycle's worth of data - please no epic week-long logs. I also only need this from 2-3 people tops - post in this thread if you've PMed so I don't get flooded please.

On a side note, I haven't actually introduced myself on here so if anyone's wondering 'who is this guy' I'm part of the engineering team. I don't post often but I do check the forums occasionally to try and get a pulse on things.

On a side note: I do not respond to PMs, unless I specifically asked for them in a thread. Our support team works with us often to try and get everyone's issues resolved, and it's important we keep following that process. Trying to ping me directly about any given problem isn't the right way to go.

Hitman50
06-02-2013, 02:31 AM
Thanks for the reports everyone. I've seen some random comments on this in other threads, but this thread has enough detail that I actually have a theory for what might be going on - it's very likely a sync problem but it will take a little more digging to determine exactly where.

For anyone who experiences this issue regularly, here's how you can help:

Tomorrow or whenever you next start a big collect cycle, take note of exactly what time and how many/what type of buildings you collect from. Then when you come back, note the states of all of those buildings. PM that information to me along with your invite code, and I should be able to reconstruct the sequence of events the server saw from the logs to fine what I need. I only need this for one cycle's worth of data - please no epic week-long logs. I also only need this from 2-3 people tops - post in this thread if you've PMed so I don't get flooded please.

On a side note, I haven't actually introduced myself on here so if anyone's wondering 'who is this guy' I'm part of the engineering team. I don't post often but I do check the forums occasionally to try and get a pulse on things.

On a side note: I do not respond to PMs, unless I specifically asked for them in a thread. Our support team works with us often to try and get everyone's issues resolved, and it's important we keep following that process. Trying to ping me directly about any given problem isn't the right way to go.

I like the honesty. its nice to see an engineer here