PDA

View Full Version : Gathering information on Lags in game



Spooneron
07-21-2017, 09:51 AM
Hello Crime City Mobsters,

We have received several reports from the community about the game Lagging during several occasions. Our engineering team is looking extensively into the issue and hence please use this thread to give us more details/screenshots/videos of instances where the game Lags for you. The more extensive the reports are, the easier it would be for us to track down the underlying issue.

As a basic checklist- please include the following minimum information in your reports-

1) Your Invite Code:

2) Your App(Game) Version, Build and Content Version: (see screenshot below)

https://lh3.googleusercontent.com/nV8nQAOLfcL69vlNQu72S3j2FnD3eexj7ZYtgb9fNic5xkyRJT 6XHSHEt5unl9JKJetRGhuEYaSxsRwbbBMbIDXwp5qQYOH32xWA DFmxeJaQ0b7IdWKpP2vuhHJ2euZIP9-vHVM3

3) Network Used: for e.g: WIFI, 3G, 4G etc.

4)What action actually led to the lag: for e.g: when tapping on Energy, Opening inventory, loading the daily ranks in HCB etc.

Thanking in advance for your efforts!

Spooneron

350zhyd
07-26-2017, 08:28 AM
As requested

Invite code : 252876225
Version: 7.9.2
Build: 648.0
Content version: 20170726_86178
Network:5G wifi

Lag occurs when loading "store" then loading "money buildings". Lag is between 5-10 seconds, on first attempt. It shortens on repeat attempts.

Lag also occurs during deployment in street assault. There is often a 5-10 second delay in pending deployments registering on nodes. On occasion the deployments fail and simply revert back to available deployments .
This is a major issue for game play when the event is based on speed of deploy to steal nodes.

Lag occurs during game login around data pushes, at times resulting in crashing out of the game.
There is also a major lag and crashing issue when reloading during Raid boss event if multiple goals have been completed.

Hope that helps

colec023
07-26-2017, 09:37 AM
Invite code : 807656228
Version: 7.9.3
Build: 310
Content version: cc_20170726_86178
Network: 4G and Wifi

Lag occurs during wars. Takes ~8-10 sec to atk and opponent and register IP. Used to be 14-16 hits/min and now its 6-8 hits/min. Hits = atk and then refill with gold.

Looking at Rivals Stats - takes 30 sec at least.

SA Deploys registering, refilling, and overall event lags, especially scores not updating.

Syn base, collecting, producing, donating, building materials, pretty much everything.

Logging in in general takes forever or switching acts.

I have posted video of how slow war is to NS on GM.

Butters1
07-26-2017, 10:11 AM
Invite Code: 958105784
Version: 7.9.2HD
Build: 468.0
Content Version: cc_20170726_86178
Network - Wifi and Data - Same issue on either
Device/OS: Apple IPad Air 2 - IOS - 11 Public Beta 3
Issue: I continue to have the same issues as stated above. However, I installed IOS 11 Beta and now I am seeing issues with logging into the game. It sits on the splash screen for approx 3-5 minutes after loading the data, sitting at 100%

jmeijer
07-26-2017, 12:17 PM
Invite code: 864128588 + farmers linked to this account
Version: 7.9.2
Build: 648.0
Content Version: cc_20170726_86178
Network: Wifi and 4G
Device: iPhone 6 / iTunes 10.3.2 (14F89)

It often takes 2 minutes to get in game, looks like it's stuck on 100% when there are new data. Very frustrating when going through my farmers.
Collect new income button doesn't always work - have to click laundromats manually sometimes.
Lag is getting worse in wars. Affects blitz speed a lot.
IOS members still don't see the Powerpod Hotel building.
Money buildings menu often takes 30 seconds to load.
It seems like every single button lags once in a while.
Sometimes when looking at syn base or kingpin menu, and exiting/going to hood, there will be giant dollar bills instead of small ones.
When speeding up LTQ, you don't always get the full amount of smuggling/legals/stars/politicals, but just 1 to 5.
It is impossible to select the number of energy refills you want to use when you want to speed up more than your current amount of energy. There appears a grey screen where you can type numbers, but the screen doesn't go to the area there you need to type the amount of refills you want to use. The grey screen only goes away when you press speed up - get a message you don't have the required energy to complete it - and then the use all energy button.

Cindee429
07-27-2017, 12:16 AM
Invite code: 963131796 IOS Device: iPhone6s
Invite code: 222156197 (Teammate) IOS Device: iPhone6
Version: 7.9.2
Build: 648.0
Content Version: cc_20170726_86178
Network: Wifi and 4G


*It takes over 2 minutes to get in game on both wifi & 4G
*Street Assault: lagging & deploys return occasionally
*Street Assault: IOS still cannot view everyone's deploys & points, we can only see our own (unlike Andriods)
*IOS members still cannot see the Powerpod Hotel
*Raid Boss: occasionally you cannot summons a boss or see that a new boss is up unless you go out of game, go to rival list or syndicate tabs to refresh.
*Pop ups: Any pop ups should automatically disappear without you having to hit the "X" every time to make them go away.
*Inventory: takes too long to view & to sort even longer to open
* no splash screen after raid boss & occasionally none after sa

Foty
07-29-2017, 10:46 AM
Invite code 641 164 795
Version 7.9.3
Build 310
Content version cc_20170728_86261

Sa takes at least 20-30 seconds to deploy and register. Sometimes they dont register at all. I have lost deploys along with others in my syn when they don't register. Many times splash screen doesn't show.

War takes 15-25 seconds to log in, attacks take at least a minute to drop four hits, wall hits dont always correspond to what's actually been done, points always have at least a 70,000 difference.

Syn base lag is ridiculous. At least a full minute to load base, then 1-2 more for each building to load and show.

Upwards of 5 mins to show a rivals profile, sometimes never shows at all.

Many times takes up to 10 mins to match during all events.

Greeny1
08-06-2017, 04:03 PM
Loading the game to start with on iOS.......start there and once you get in work on the other lags listed above.....

sfun
08-12-2017, 01:58 AM
Invite code : 107310437
Version: 7.9.3
Build: 310
Content version: cc_20170726_86587
Network: 4G and Wifi


Lag makes the game unplayable. SA is the worst since you dont see anything correctly. The score, the amount of deploy pending, what deploys you still have. And most importantly you are unable to compete against people who have no lag. When full and starting to deploy at 30min mark i can drop max 2k deploy. While others can do 3k+ deploys within 10-15min. Even if wanted to im unable to compete. Since SA and war are team events the impact is rather small. But it still feels **** that you can help your team out more.

Syndicate Base i hardly even bother. Starting a boost takes 1-2min. And producing and collecting all five resources takes 5min. I can not even open the Underground Lab while we have an upgrade pending.

With each step you do, you will witness lag, but Syndicate base and SA are the worst.

Butters1
09-07-2017, 02:45 PM
Are there ANY updates to this? We are a month and a half into this and we are still having issues.. IF you have any updates... Please provide.

If you need a tester, let me know !!!!

DoomsdayMY
09-08-2017, 03:24 PM
With all due respect to the people people posting above, I don't think you're getting the answers you want. I play on both Android and Apple tablets, primarily. If you don't play both, you don't see the real issues.

On my iPad Pro, almost every action has a sub 1 second response - except the store which lags a couple of seconds. On my Android tablet, every action has a 3 to 7 second minimum response time. Certain things take a lot longer. Getting an opponents profile could take 30 seconds, but you seem to have made improvements on that in the last few days.

Putting this into context, on the iPad, I can collect 5 and build 5 resources in the Syndicate base in little over 1 minute. On Android, it takes SEVEN minutes minimum. In battles, I can deploy 3 or 4 on the iPad but only 2 on Android in the same time.

When I said "Every action", I do mean that. Everything from collecting your cash when you login, loading event screens, doing jobs - literally everything. The dreaded green spinning circles makes at least 3 or 4 revolutions before anything happens.

A few months ago, I setup a proxy server on my laptop and connected both tablets through that to determine whether it was Android tablet that was the problem or the server. The response time from android.crimecity.com was 10 - 25 times longer for the same action than from ios.crimecity.com. My development experience is with commercial software on Windows not games, so I'm not going to speculate on the specific cause. However, it is almost certainly server side, not client or connection.

If it helps, the Android device was just as fast as the iPad before the Syndicate base was released.

Mrs Cash
09-18-2017, 12:43 PM
Everything DoomsdayMY said was spot on. I play on 2 Android devices while dh has an iPhone. Tasks on his iPhone are significantly faster. I just collected his SB resources and it was done in a flash, all 5, collected and restarted production, in under a minute. That cannot get done on either of my Androids even in 2 minutes. And forget it when I have to switch accounts. First you have to switch, which goes thru the entire startup phase. Usually a KingPin splash, sometimes 1, sometimes over 10, that needs to be x'd out. Earlier I had to x out 13 times, all for a level 3 KingPin. 13?!?!?! Then I need to quit the game and restart it, otherwise SB buildings won't let me collect. Then I have to go thru the startup splashes all over again. Plus, the level splash, then the skills splash, each and every time, every account switch. Its infuriating. Just to collect and produce resources can take about 5 minutes. For each account. Absurd...

No ltqs = no powers =no production. What gives? There is still the horrible lag. There was 6 minutes left in a recent battle. Got 2 hits in on my main, switched to my 2nd acct, took a hit, and got the spinner for over 60 seconds. Cancelled that and retried, nothing but a spinner (that buffering, i am trying, circle). Gave up and switched accts. Sane thing on acct #3. Buffering, buffering, buffering. Finally went thru. 2nd hit never got a chance, battle over. 6 minutes and 3 hits in on 2 accounts, 2 accounts didn't get in. Absolute BS.

Butters1
09-28-2017, 10:05 AM
Is there any updates on this? This issue has been going on way to long and it's becoming very difficult to even play. Many in my syn have quit playing...so what's going on

Mrs Cash
10-01-2017, 08:38 AM
They stop the ltqs during battles because it adds to the lag, allegedly.
They halt gold sales to gain more data for the lag, allegedly.

Shocker, the lag is still obscene. What a clusterf***.

Mrs Cash
11-26-2017, 08:17 PM
The lag during the last minute of a SA is RIDICULOUS! Tried to rapid tapped 133 deploys, which normally isn't much of a problem, but just now, deploys were deployed, node turned our color, then the deploys kicked back and the nodes color reverted back. Its infuriating. Gree, Deca, whomever is in charge of fixing this cluster**** of a game needs to get with the program already.

Dat Guy
12-13-2017, 03:33 AM
The lag during the last minute of a SA is RIDICULOUS! Tried to rapid tapped 133 deploys, which normally isn't much of a problem, but just now, deploys were deployed, node turned our color, then the deploys kicked back and the nodes color reverted back. Its infuriating. Gree, Deca, whomever is in charge of fixing this cluster**** of a game needs to get with the program already.

Exactly this. If there is less than a minute left, I don't even bother trying to get into the map area. I know I will never get in there in time, let alone be able to deploy anything that will register.